PDA

View Full Version : How do I get rid of the force close problem after upgrading from v1.04?



Howard
12-05-2009, 12:35 AM
This only applies to users that are upgrading from v1.04 to a later version. All versions released after Oct. 30, 2009 do NOT have this problem.

Versions after v1.04 have a sharedUserId specified which lets the Android application security system know that the applications are allowed to share data between the different editions. However there is a bug in the Android application security system which is mistakenly preventing versions after v1.04 from accessing the database that was created by v1.04, even though it is the same application package and is signed with the same security key. The only way to resolve this problem is to delete the older database and have the newer version create a new database. Unfortunately even after uninstalling the program, the Android application security system sometimes remembers some information which may prevent a later install from successfully creating and accessing a new database. If this happens to you, please follow these steps:

1) Uninstall the Ambling BookPlayer application.
2) Power off the phone (hold down the hang up button and then select power off from the pop up menu).
3) Power on the phone.
4) Install the Ambling BookPlayer application again.

You will have to reload the book descriptions for the books you are listening to. The player will automatically detect that the audio files for the book are already present on your SD card and will not download them again.

We sincerely apologize for the inconvenience this problem is causing. Because it is a problem in the Android application security system we are unable to resolve the issue in our application.