PDA

View Full Version : Ambling Book Player Pro v2.04 can't add books from SD card



gmiossi
12-17-2010, 12:00 PM
Hi,

I just upgraded to v2.04 of the Pro player and I can't add books from my SD card now.

I've tried: uninstall & reinstalling. Clearing all application data from Settings->Manage Applications. Adding a book on my SD card that I previously had loaded successfully.

As soon as I choose "add selected files" a separate process loads in the 'system tray' area. If I drag that down it says 'reading audio file information...' and it never changes, no matter how long I wait. If I tap that it takes me to the standard 'adding audio files' window I used to get, but the progress bar never moves.

I'm running Android 2.2 (on a Droid X phone). It's not rooted or anything like that.

Is there a way I can revert back to an old version in the short term?

I have truly loved your app, by the way (present bug notwithstanding) - I use it constantly. The features are excellent - everything I could ever have dreamed up wanting in such a program. I use it with a blue tooth headset and, alternately, a cable to my car's receiver. I recommend it to everyone I can, but unfortunately there aren't many people passionate enough about reading to be interested in pursuing audio books in spare moments of their lives.

Thanks for your help on this issue,
Graham

gmiossi
12-17-2010, 06:29 PM
Nevermind, I figured the problem out. It's true that I couldn't add SD cards in the new version, but that was actually because the default skin had been changed in the upgrade. With the new skin (which I do like), I can't add books for some reason.

After switching back to the classic skin I had no problems adding books again.

Howard
12-19-2010, 12:41 AM
In v2.04 the code which adds the audio files to a book from the SD card has changed. It now uses a different mechanism to process the audio files to read the ID3 tags and the audio file play duration. This change was made as part of adding a new feature to allow sorting the audio files to be loaded using the ID3 tag disk number and track number values, in addition to the previous support for sorting the files alphabetically by name.

We have found two issues that are a result of this new code in v2.04.

1) Previously the player would read .mp3 files even if they had a different file extension. However now the file extension has to be .mp3 (or .mp3.ab) in order for an .mp3 file to be read by the player.

2) There are some cases when there is an error reading audio files where the screen that shows the error messages does not get displayed. The cases where the error screen is not displayed are 1) if none of the files that were processed were recognized as a valid audio file, or 2) if after finding a valid audio file there are no additional files with errors.

For issue 1, please make sure that your .mp3 audio files have the proper extension.

For issue 2, please be aware that if the audio files you selected did not load there may be a problem with the audio files, even though an error screen was not displayed. We have coded a fix for this issue which will be included in our next release.

The choice of which skin you are using for the player should not impact the code which loads the audio files. I think it may have just been a coincidence that after you changed the skin your next attempt to load the audio files was successful.

kevinjanet
01-05-2011, 11:23 AM
Like the original poster I can't load any files from SD card. I tried several books including ones that I had just loaded a week before. The mp3 files are good they just won't load. I tried uninstalling and reinstalling etc etc.

I can download files from the internet. Is their a way to get the old version so I can start using my book player again? You must have the old version on hand. just send me a link and I'll manually install it.

THanks,

Kevin Hall

DroidX phone

kevinjanet
01-05-2011, 05:20 PM
I found version 1.7 on the web and installed that instead of 2.04. It downloads from the SD card perfectly. Since I am using several of the same books that version 2.04 wouldn't download, I think we can safely point to a software problem rather than bad mp3 data or invisible errors (as another post suggested)
Here is hoping version 205 comes out soon and that it addresses this issue.
Maybe it is a DroidX issue since the complaints I have seen all seem to involve that phone.

bovineyard
01-05-2011, 07:57 PM
I also am having the problem of the loader freezing up when adding books from SD card or onboard memory (droid incredible). I downgraded to 2.03, and the problem went away. Fortunately, I had a backup copy of 2.03 before I upgraded.

vern
01-13-2011, 08:47 AM
Having the same issue on my Droid X froyo 2.2.1 with version 2.04. I loaded one book with 258 files just fine when I went to load a second book with 254 files it hangs on the adding audio files. The first book still plays fine. The files for the second book are all .mp3 and have been use on an mp3 player before. The big problem is not being able to see if there is an error or anything then haveing to reboot the phone to get it to clear the program from memory, telling it to cancel just hangs as well.

Howard
01-13-2011, 02:25 PM
It appears that many users of the DroidX are seeing this same problem. We are working to track down the issue on this device and have a beta build of the next v2.05 release. If you are willing to try the v2.05 beta to let us know if it helps with this problem please email us at support@amblingbooks.com.

TVo
01-14-2011, 12:35 PM
I too am having an issue with adding files from SD card (including books that worked before).

I noticed you guys are using the .ab file extension to keep the files showing up in the music player. I did a "fix" a while back by placing a .nomedia file in my AudioBook Folder to do the same thing. Could this effect the books from being added?

Anyway, using 2.04 on a Droid2. Been very satisfied with the product. This is my first issue.

Thanks

Howard
01-16-2011, 03:19 PM
When you attempt to load the audio files do you have a .nomedia file in the directory with the audio files? Have you checked to see if it makes a difference if this file is present or not present?

The v2.04 code uses the Android ContentResolver functionality for reading the ID3 tags and it is possible that the presence of a .nomedia file could be keeping the ContentResolver from reading the files.

I tested it with and without a .nomedia file on my Droid to see if it would help me to reproduce the issue, but it reads the files both ways. For some reason the DroidX and Droid2 seem to be behaving differently than the Droid which I am using for testing.

Please let me know if the presence or absence of the .nomedia file makes a difference in the behavior on your phone.

TVo
01-16-2011, 04:30 PM
No, the absence or presence of a .nomedia file has not yet made a difference.

I've tried it with both, and also tried it WITHOUT the .ab file extension enabled.

Howard
01-17-2011, 01:47 PM
We have been able to reproduce this issue, and will have a fix in the next release, which will come out soon.

The problem is dependent on 1) the type of Android device, 2) the Android OS version running on the device, and 3) the name of the file which you are adding. The problem only occurs when there are certain characters in the file name which will cause SQL statements to become malformed, like a single quote character. Apparently on some devices with some versions of the Android OS the Android ContentResolver did not properly escape the file name characters before executing an SQL command using the file name. This causes an SQL exception in the ContentResolver code and the exception handling code does not properly do a callback to the waiting application. Google apparently found this problem and fixed the ContentResolver to properly escape the characters in the SQL statement in later releases, which is why the problem is only happening on certain devices and Android OS versions.

There is a work around for this problem which is to rename the files which cannot be loaded to not include any special characters such as a single quote in the file name. If you rename the audio files you will be able to load them into the player without any problems.

We will release a v2.05 update with a fix to work around the Android ContentResolver problem on these devices soon.

TVo
01-17-2011, 02:18 PM
That was definitely my problem.

I removed the 's from my file names and directory and it added without problems.

Thanks for helping figure this out!

Howard
01-20-2011, 07:29 PM
The issue with audio files with non-alphanumeric characters in the file name not being able to be loaded into a book has been fixed in the v2.05 release which is now available.