PDA

View Full Version : Skips ahead when un-pausing



LMaccherone
01-04-2010, 08:39 AM
I downloaded 1.11 this morning and also upgraded to the Pro version. I didn't really need the Pro features but I figured you deserved the $13 for the amount of use I get out of Ambling and the wonderful/quick support that you provide. After I did that, I noticed an issue with it skipping ahead by 22 seconds when I unpause a book. It also seems to skip ahead 1 second when pausing but that may be a sub-second display subtlety.

It's possible that it always did this and I just never noticed. 22 seconds is not enough for me to notice if I only pause and play between times in the car. The only reason I noticed this morning is because I was paying close attention to it while I experimented with the new capability to pause and play using the headset button (I love that feature).

BTW, I love this player and the support you provide. Keep up the great work! Feel free to use me as a testimonial.

Howard
01-05-2010, 12:24 AM
Thanks for all your kind comments. It is very nice to hear when people appreciate our player.

The skipping ahead may be an issue with the Bluetooth media button on your headphones. You can control the player from the headphone buttons, and by default the forward button will skip ahead 15 seconds. I know on the Bluetooth headphone that I have, the same button is used for play/pause and for forward and reverse. I have to be very careful when pressing the button in for the play/pause function to avoid pressing down or up on the button at the same time.

A quick way to check if this is what is happening would be to go into the preference settings and change the amount of time the Bluetooth forward and reverse buttons jump in the book. Then check to see if that has changed how far it skips ahead when you press to pause. Also you could check the instructions for your headphones to see where the forward and reverse buttons are located (sometimes there are two different sets with one for fast forward and the other for next audio file, although the Android AVRCP implementation currently doesn't support the second set).

LMaccherone
01-05-2010, 07:36 AM
The problem happens even when I'm not using any headset. I can be using the speaker on my Sprint Hero with no headset plugged in and the display show that the marker is at 5:8:19 while it is paused. The instant that I hit the green arrow, the display changes to 5:8:41.

However, based upon your comment, I started playing with the Forward/Reverse Skip Time in Preferences and it had a strange effect. Before this round of playing, the amount of time it skips was always 22 seconds, as I've said. I could do this 100 times and it was always 22 seconds. I tried increasing the Forward/Reverse Skip Time to 60 seconds, the unpausing skip ahead then became 26 seconds... every time. But that's not the most strange behavior. When I change it back to the original 15 seconds, the unpausing skip ahead is still 26 seconds now... every time. No further changes seemed to impact it. I then tried rebooting. It stays at 26 seconds.

I tried the following settings and none of them seemed to have any effect:
- Forward Jumps Backward
- Jump Back After Pause
- Headset Unplug Pause
- Headset Connect Play
- DPAD Buttons Jump (however I don't have a DPAD on the Hero and when I flick the trackball to the left, it still skips forward.)
- Play Next in Series
- Move Between Books
- Resume After Phone Call is set to Do Not Resume but when I set it to 5 Seconds it doesn't seem to have an effect.

As a programmer myself, I'd guess that there was some value that's changed when you exit the Forward/Reverse Skip Time dialog. That value is stored with the settings and is used (in some way... maybe in an expression) to place the marker whenever the pause/play toggle is activated. I'd look in the serialization code that is run when exiting the Forward/Reverse Skip Time dialog and double check the logic in the methods that are called when the pause/play toggle is pressed.

BTW, it's not a Bluetooth headset. It's a wired headset with a single button like the ones that come with the iPhone. The button on the headset behaves the exact same way as if I had pressed the pause/play green arrow in Ambling.

Howard
01-05-2010, 09:36 PM
Thanks for providing the detailed description of the issue you are seeing. I have tried to reproduce this but do not see the behavior. Could you let me know if this happens for all audiobooks or is specific to certain audiobooks? Does the file type mp3 or ogg make a difference? Does the size of the audio files being large or small make a difference?

LMaccherone
01-05-2010, 10:10 PM
I only have one other audiobook loaded on the device at this time. It skips ahead 11 or 12 seconds when unpausing.

They are both WMA 9.2, 20kbps, 22kHz, mono, files output from GoldWave converted .aa files. The one that skips ahead 26 seconds is 7:22 and 67MB. I could send it to you if you wanted. The other is similar in size. 6:20.

BTW, I tried using Android's music app on these same files and it does not exhibit the same behavior.