View Full Version : Book Showing up as Music

03-07-2010, 06:02 AM
I downloaded a Simply Audio book to my computer & then to my Droid. When I opened the files I realized that they had loaded out of order. I went back into the file on my computer and just downloaded the first 99, since those were only two digits and would transfer in the right order. When I downloaded only the first 99 files, they came into my Droid as music, and I can't open that file from my Ambling Book Player.

How do I get these files to load as a book so that I can read them from my Ambling Book Player?

03-07-2010, 10:14 AM
The first step is to make sure the audio files have been copied to a folder on your SD card and that you know the name of the folder where you copied the audio files.

Depending on what music player you are using, your music player may automatically discover these files and add them to its list of music. We don't have any control over what your music player does. A few people have told me that they actually removed the file extension so that their music player wouldn't recognize the files as audio files. At any rate whether your music player automatically discovers the audio files has no impact on how you load the audio files into the Ambling BookPlayer.

To load the audio files as an audiobook in the Ambling BookPlayer, please see the instructions in this forum at http://amblingbookplayer.com/forums/showthread.php?23-Adding-an-Audiobook-From-the-SD-Card

03-07-2010, 12:39 PM
For those who have Droids, that is the answer. The audio files must be contained in a folder, in order for the Ambling Bookplayer to access the files.

03-07-2010, 05:56 PM
If your audio files are in a folder like /sdcard/ which contains both files and sub folders then you will need to use the buttons labeled "View Files" and "View Directories" to toggle between viewing the sub folders, and viewing the files. These buttons are are located at the top of the window when browsing your SD card contents. The button being shown will change depending on if you are currently looking at the file listing or the folder listing.

It is usually best to put your audio files in their own sub folder just so they are easier to manage. It is easier to keep your files organized as you go along, rather than trying to sort them out later when you find there are too many files in the /sdcard/ folder.

03-08-2010, 02:31 AM
It is pretty easy to prevent your audiobooks from showing up in your mysic player. Just make a folder for your sdcard e.g. Audiobooks and make sure the foldername starts with a period.


Place all your audiobooks in this folder. This way, the music player, will not show the audiobook files.

05-10-2010, 06:29 AM
I hadn't checked back with this forum until today, because for some reason, files had been loading correctly. Since I again had a problem, I checked back just to see if anyone had come up with a solution. That is REALLY easy, and it did solve my problem. THANKS!

05-13-2010, 01:19 PM
In v1.17 we added an option to have the player rename the audio book files to have a .ab extension. This will prevent the music player from finding the files. Because of an issue with the Android audio system, which cannot play .ogg files which have had the extension modified, we changed this setting in v1.18 so that it is not turned on in the preferences by default.

If you are loading audio books from the SD card which are not .ogg files then you can reenable this preference setting.

In our next release we will have this turned back on as the default behavior, but the player will skip automatically renaming specific file types such as ogg which will not play if they have been renamed.

05-29-2010, 05:20 PM
The v1.19 release adds support to recognize the audio file formats which won't play anymore if the file extension is changed. The option to add the ".ab" extension can now be reenabled in the preferences as the player will know not to change the extension on the audio file types which won't work if the extension is changed.